iView home page
iView Multimedia Forum Index

FAQ FAQ     SearchSearch     MemberlistMemberlist     UsergroupsUsergroups    RegisterRegister  
ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

VBScripts die w/ err->Activex component can't create obje

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    iView Multimedia Forum Index -> VB Script
View previous topic :: View next topic  
Author Message
freeform



Joined: 12 Feb 2007
Posts: 2

PostPosted: Thu Feb 15, 2007 4:21 pm    Post subject: VBScripts die w/ err->Activex component can't create obje Reply with quote

Every script I've tried dies on the line:

Set app = CreateObject("iView.Application")

and yields the error:

Activex component can't create object

In Excel's VB editor I get a runtime error of 429.

Iview's error pop-up reports "Error:0 Scode:800a01ad.

The Iview VB Script forum has a few posts mentioning a similar error, but I did not see any solutions on how to fix it. The Microsoft support site mentions many possible causes, most or all that are "computer specific".

I see this problem on my laptop (XP Pro/Excel 2003). I do not get this on my home PC (XP) where the same scripts run fine.

Before I go down the many debug paths offered by the Microsoft site, does anyone have a suggestion on what might be wrong?
Back to top
View user's profile Send private message
johnbeardy



Joined: 22 Nov 2004
Posts: 1137
Location: Dulwich, South ("Sarf") London

PostPosted: Thu Feb 15, 2007 5:25 pm    Post subject: Reply with quote

Usually that would indicate the Windows scripting engine doesn't know what application the script is trying to automate. Check your iView installation.

John
_________________
PC and Mac too
iView scripts & utilities
Back to top
View user's profile Send private message Visit poster's website
freeform



Joined: 12 Feb 2007
Posts: 2

PostPosted: Thu Feb 15, 2007 9:13 pm    Post subject: Reinstall helped Reply with quote

Thanks John!

A reinstall of IVMP 3.1 fixed the problem. I suspect that an uninstall of IVMP 2.6 after the install of IVMP 3.1 is what messed up my script running capability on my laptop. I believe I had uninstalled IVMP 2.6 prior to installing IVMP 3.1 on the computer that runs scripts fine (but I don't know for certain).

John, thanks also for the tip on hooking up Iview to Excel so that I can debug custom scripts.
Back to top
View user's profile Send private message
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    iView Multimedia Forum Index -> VB Script All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



  © iView Multimedia Ltd. | All Rights Reserved Privacy Policy | Copyright | Site Map